CompEvo Help

>> На главную
> Содержание справки
> Начинаем игру
> Начальное железо
> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Здравствуйте, уважаемые игроки!

Перед вами находится 4-я версия справки к игре "Компьютерная революция". Этот "выпуск" справки написан для игры версии 4.0.3, и некоторые описанные в нем возможности не встречаются в ранних версиях.

Новое в этой справке:
  • Немного изменен дизайн, благодаря чему была исправлена (я надеюсь:) ) ошибка с налезанием картинок на текст при низких разрешениях (thx All, а особенно haM3r)
  • Немного обновлены данные и скрины
  • Обновлены данные по авторам статей
  • Добавлена страница про создание плагинов, чтобы вам не приходилось скачивать две справки
  • К справке добавлена функция поиска
Иллюстрации в справке черно-белые для уменьшения "веса". Если Вы пришли в поисках ответа на какую-либо тему и не можете найти ее, посетите раздел Содержание справки, если же Вы новичок, рекомендуется просто проходить все разделы по порядку. Желаю Вам хорошей игры!

Все отзывы по справке пишите мне и Павлу на e-mail.

С уважением, Голубев "FLYM" Михаил
Справку сделал

Mailto: ADMIN@COMPUTER-NEWS.RU
URL: COMPUTER-NEWS.RU


> На главную
> Начальное железо
> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
>> Содержание файлов

> Сайт игры

Содержание файлов

Если у Вас есть списки оборудования или софта, подобного тому, который используется в Компьютерной эволюции, но вы не знаете, как добавить его в файлы игры, тогда в этом разделе вы найдете описание структуры большинства файлов. Между полями (напр. Название и Дата) !обязательно! делайте табуляцию (клавиша Tab на клавиатуре). Если вы добавили новое оборудование в игру, не поленитесь, пошлите файл Ревенкову Павлу на e-mail. ;-)
Видов платформ (ОС) в игре 5: Win, Lin, BSD, Be, OS2.

Data\Antispam.dat — список Противоспамных фильтров.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Antivirus.dat — список Антивирусов.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|") - Адрес сайта обновления

Data\AudioEncoder.dat — список Программ для сжатия аудио.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место - Платформы (разделяются знаком "|")

Data\Benchmark.dat — список Программ-тестеров.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место - Платформы (разделяются знаком "|")

Data\Broswer.dat — список Браузеров.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Car.dat — список Машин.
Структура:
Название - Год выхода - Цена (д. е.) - Удобство

Data\Cdrom.dat — список Оптических приводов.
Структура:
Название - Год выхода - Скорость записи DVD-R - Скорость записи DVD-RW - Скорость записи CD-R - Скорость записи CD-RW - Скорость чтения CD-ROM - Цена (д. е.)

Data\Cooler.dat — список Кулеров.
Структура:
Название - Год выхода - Цена (д. е.) - Количество оборотов в минуту - Уровень шума (дб)

Data\CopyCD.dat — список Программ для копирования дисков.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Cpu.dat — список Процессоров.
Структура:
Название - Год выхода - Цена (д. е.) - Производительность - Коэффициент умножения - Частота системной шины (МГц) - Чипсеты (разделяются знаком "|")

Data\Defragmenter.dat — список Дефрагментаторов.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Development.dat — список Сред разработки.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|") - Сокращенные названия языков (разделяются знаком "|")

Data\DiskOperator.dat — список Программ для работы с диском (управление разделами).
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Firewall.dat — список Файрволлов.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Flat.dat — список Квартир.
Структура:
Название - Цена (д. е.) - Удобство - Квартплата (д. е.)

Data\Games.dat — список Игр.
Структура:
Название - Год выхода - Требуемая производительность видеокарты - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Hacking.dat — список Программ для хакерства.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Harddisk.dat — список Винчестеров.
Структура:
Название - Год выхода - Объем (Гб) - Скорость вращения шпинделя (rpm) - Цена (д. е.)

Data\Keyboard.dat — список Клавиатур.
Структура:
Название - Год выхода - Цена (д. е.)

Data\Manager.dat — список Файл-менеджеров.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Data\Modem.dat — список Модемов.
Структура:
Название - Год выхода - Цена (д. е.) - Скорость (k)

Data\Monitor.dat — список Мониторов.
Структура:
Название - Год выхода - Цена (д. е.) - Диагональ (") - Относительная безопасность

Data\Motherboard.dat — список Материнских плат.
Структура:
Название - Год выхода - Чипсет - Смена частот (Y или N) - Смена напряжения на процессоре (Y или N) - Смена коэффициента умножения (Y или N) - Цена (д. е.) - Поддерживаемые шины для видеокарты (разделяются знаком "&") - Поддерживаемый тип оперативной памяти - Поддержка двух видеокарт (разделяются знаком "&")

Data\Mouse.dat — список Мышей.
Структура:
Название - Год выхода - Цена (д. е.)

Data\OS.dat — список Операционных систем.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформа - Тип файловой системы (разделяются знаком "|")

Data\Power.dat — список Блоков питания.
Структура:
Название - Год выхода - Цена (д. е.)

Data\Printer.dat — список Принтеров.
Структура:
Название - Год выхода - Цена (д. е.) - Скорость (страниц в минуту)

Data\Ram.dat — список ОЗУ.
Структура:
Название - Год выхода - Цена (д. е.) - Объем (мб.) - Тактовая частота (МГц) - Тип

Data\Scanner.dat — список Сканеров.
Структура:
Название - Год выхода - Цена (д. е.) - Скорость (страниц в минуту)

Data\Sound.dat — список Звуковых карт.
Структура:
Название - Год выхода - Цена (д. е.)

Data\Speakers.dat — список Колонок.
Структура:
Название - Год выхода - Цена (д. е.)

Data\Tower.dat — список Корпусов.
Структура:
Название - Год выхода - Цена (д. е.)

Data\UPS.dat — список Источников бесперебойного питания.
Структура:
Название - Год выхода - Цена (д. е.) - Надежность

Data\Videoboard.dat — список Видеокарт.
Структура:
Название - Год выхода - Чип - Производительность - Объем памяти (мб.) - Тактовая частота памяти (МГц) - Тактовая частота ядра (МГц) - Цена (д. е.) - Используемая шина - Поддержка двух видеокарт

Data\VideoEncoder.dat — список Программ для сжатия видео.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место - Платформы (разделяются знаком "|")

Data\Videosoft.dat — список Программ для разгона видеокарты.
Структура:
Название - Год выхода - Цена (д. е.) - Занимаемое место (мб.) - Платформы (разделяются знаком "|")

Inf\Asm.inf — код создаваемой на Ассемблере программы.

Inf\Auction.inf — имена людей, принимающих участие в аукционе, по одному на строку.

Inf\Bas.inf — код создаваемой на Basic программы.

Inf\Cpp.inf — код создаваемой на C++ программы.

Inf\Domain.inf — список доменов для создания сайта, по одному на строку.

Inf\E-mail.inf — список доменов для создания e-mail'а, по одному на строку.

Inf\FileSystem.inf — файловые системы, по одной на строку.

Inf\Iwork1.inf — вопросы для первой категории (написанные в них деньги только выводятся пользователю, а выплачиваются ему другие, так что Вы не получите 1000000 д. е. :-)).

Inf\Iwork2.inf — вопросы для второй категории (написанные в них деньги только выводятся пользователю, а выплачиваются ему другие, так что Вы не получите 1000000 д. е. :-)).

Inf\News.inf — новости, время от времени выводимые пользователю.
Структура:
Новость - Год

Inf\Pas.inf — код создаваемой на Паскале программы.

Inf\Players.inf — имена игроков, по одному на строку.

Inf\Records.inf — рекорды.

Inf\RW.inf — просьбы при пиратстве.
Структура:
Просьба - Год - Количество дисков для записи - Тип (audio, soft, video) - Легальное ли это действие (Y — да, N — нет)

Inf\Spam.inf — спам, получаемый пользователем.

Inf\Study.inf — сообщения, с которыми пользователь вылетает с учебы.

Inf\Text.inf — просьбы для сканирования/распечатки.

Inf\Unix.inf — каталоги взламываемых Unix-машин.

Inf\Windows.inf — каталоги взламываемых Windows-машин.

Sites\Адрес\page.ini — параметры сайта.
Caption=Заголовок сайта.
AddPoints=Изменяемый параметр при посещении сайта.
Count=На сколько этот параметр изменяется.
Подробнее в разделе: Создание сайта


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
>> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Хакерство

Для начала скажу, чтобы начать хакерство, нужно иметь статус не ниже Продвинутого. Также нет смысла хакерить, если у Вас не имеется файлового менеджера, как же Вы будете передвигаться по компу жертвы без него? Также в версии 4.0.2 хакерить до 2003 года приходится, надеясь на удачу, т. к. только в этом году появляется так нужный нам Anti-firewall. Вообще из хакерского софта вполне достаточно переборщика паролей и анти-файрволла. Если Вы очутились в 2004 году, сразу купите и Stealth маскировку, она поможет Вам неописуемо долго быть на компьютере жертвы. Когда Вы находитесь на компьютере жертвы, Вы можете удалить папки (увеличение настроения), взломать некоторые программы (например, когда вы на компе с Windows, если Вам повезет и Microsoft не залатает свой софт), а также скачать так называемую "Секретную программу". Последнее (точнее, скорее всего, первое), что нужно помнить - это то, что лучше для хакерства себе на комп поставить Linux, OS/2 или BSD систему, т. к. под ними идут большинство хакерских программ.

В CompEvo 4 появилась возможность красть ICQ-номера, для этого вам потребуется программа "Переборщик паролей". Вы должны вторгнуться на компьютер под управлением ОС Windows, зайти в каталог C:\Program Files\ICQ, нажать правую клавишу и выбрать "Подобрать пароль", при условии удачного подбора пароля, вы можете выставить номер на аукционе, старайтесь не ставить слишком высоких цен на номера, максимум около 3000 д. е., однако при высоких ценах взломанный ICQ-номер могут и не купить. При удачном стечении обстоятельств кража ICQ может стать вполне прибыльным бизнесом.

Это было небольшое описание всего хакерства, теперь описание интерфейса. Когда Вы откроете окно хакерства ("Работа с интернетом" - "Хакерство"), перед Вами предстанет окно приветствия. Нажав кнопку "Программы" Вы можете купить нужные хакерские программы (табл. 2).

Таблица 3
Название | Дата выхода | Цена (д. е.) | Нужное семейство ОС | Вес (мб.)
Переборщик паролей | 2000 | 250 | Win, Lin, BSD, Be, OS/2 | 8
Файл-бомба | 2001 | 314 | Lin, BSD | 10
Сетевой вирус | 2002 | 459 | Win, Be, OS/2 | 4
Anti-firewall | 2003 | 519 | Win, Lin, BSD, OS/2 | 20
Stealth маскировка | 2004 | 753 | Lin, BSD, Be, OS/2 | 45

Если вы хороший программист, то сетевой вирус вы можете написать сами в разделе "Создание программ".

После покупки направляйтесь в раздел "Соединение", если у Вас стоят переборщик паролей и anti-firewall, вы спокойно подключитесь. Теперь направляйтесь во вкладку "Хакерство", если у Вас есть Stealth-маскировка, включите ее (правая клавиша мыши, последний пункт в открывшемся меню), теперь можете спокойно, не торопясь смотреть папки, удалять, качать, взламывать.


> Как добыть деньги?
> Характеристики игрока
>> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Железо, софт: краткое описание

Здесь представлено лишь краткое описание железа и софта, если Вы хотите сравнить одну железку с другой, посетите раздел Содержание файлов, в котором рассказано, как устроены игровые файлы, после этого вы сможете их просмотреть.
Железо
Необходимый комплект железа: Процессор, Материнская плата, Оперативная память, Жесткий диск, Монитор, Блок питания, Клавиатура, Мышь. Также практически невозможно выжить без привода, т. к. без него вы не сможете поставить софт.

Примечание: советы по выбору начального железа Вы можете найти соответственно в разделе Начальное железо

Для работы Вам этого достаточно, но рекомендуется еще купить модем, чтобы иметь возможность серфить в интернете.

Оптический привод нужен для установки программ, а также для пиратства (пишущий). Сканер и принтер нужны для удаленной работы. Видеокарту же можно сменить со встроенной на более хорошую для того, чтобы играть.

Для покупки железа зайдите соответственно в пункт "Покупка железа", затем выбирайте, какой вид оборудования Вы хотите купить, откроется окно, в нем будет раскрывающееся меню с оборудованием, вышедшим в этом году в этой категории. После выбора оборудования вам покажут его характеристику, а также полосу стоимости, показывающую стоимость данного устройства по отношению ко всем вашим деньгам.

Если Вам не хватает денег, выберите в окне, вызывающимся по кнопке "Покупка железа", "Радиорынок", здесь товары дешевле, но они могут быть в плохом состоянии.

Если Вы хотите узнать насколько "крут" Ваш железный друг, установите программу-тестер, затем нажмите кнопку "Тест железа", начнется тест, после этого Вам выведут результаты. Вы также в результатах можете разогнать процессор и видеокарту.

Чтобы полностью можно было управлять процессором, рекомендуется покупать материнскую плату со всеми 3-мя возможностями доступными. Теперь можете менять. Также если у Вас новый процессор Вы можете включить технологию Hyper-Threading. Что рекомендовал бы я: повышение FSB, дает ощутимый прирост, на Athlon 64 FX-55 FSB удавалось поднять на 40 вверх (без изменения других параметров). При повышенном FSB удалось повысить напряжение на 25, увеличение не дало абсолютно никаких преимуществ, зато разгонщик перестал "материться" о зависаниях компьютера. При манипулировании данным параметром нужно быть осторожным! Я лично сжег 3 процессора при этом. :-) Множителем можно манипулировать вместе с FSB, нужно достигнуть некой "золотой середины" между FSB и множителем. У меня лично получилось разогнать процессор с 2600 до 3302 МГц при значениях: FSB 254, Напряжение: 1,75, Множитель: 13. Наверняка, это не предел. Присылайте мне на e-mail Ваши разгоны вместе с параметрами.

Чтобы разгонять видеокарту, нужна программа для разгона, она покупается в окне, вызывающимся по одноименной кнопке в окне "Разгон видеокарты". Я бы порекомендовал Вам вначале автоматически выбрать оптимальные настройки, а затем немного повысить их, однако можно свободно экспериментировать, у видеокарты ничего не сгорит, не взорвется и т. д., а Вам любезно сообщат, что видюха не может работать с такими настройками. Также у видеокарты есть возможность экстримального разгона. Его можно открыть из окна простого разгона. В окне "Экстримальный разгон" все подробно описано, замечу лишь то, что он заключается в покупке и установке на вашу видеокарту различных устройств. Здесь можно легко спалить вашу видеокарту, так что будьте осторожны!

Теперь немного о разделах на винчестерах, вы можете создавать, форматировать и удалять их, зайдя по кнопке "Изменение структуры разделов" из окна установки новых программ. В принципе здесь все просто и понятно (если есть вопросы, пишите мне на e-mail, я обязательно рассмотрю их в справке), только имейте ввиду, что для установки операционной системы раздел должен быть основным и активным (для изменения активного раздела щелкните по кнопке "Смена активного раздела" в окне установки новых программ).

Софт
Большинство софта, кроме бесплатного и софта для пиратства, предоставляются в двух вариантах: лицензионный и нелицензионный. Они, в принципе, одинаковы, у обоих время от времени вылетает установка, но от лицензионки у Вас растет рейтинг. Есть несколько мест, где можно купить разные виды софта:
1. Щелкните "Программное обеспечение" в главном окне, здесь вы можете купить:
  • Операционную систему — она нужна для работы всего и вся.
  • Средства разработки — для создания собственных программ
  • Антивирус — для избавления от вирусов, которые могут "грохнуть" Вашу ОС со всеми программами
  • Противоспамные фильтры — если Вам надоел спам, поставьте противоспамный фильтр!
  • Брандмауер — нужен для защиты Вашего компьютера
  • Браузер — для серфинга по сайтам
  • Файловый менеджер — для перемещения по компьютерам жертв при хаке
  • Программа-тестер — для тестирования характеристик своего железа
Также в этом окне Вы можете дефрагментировать (если комп медленный) и форматировать (если у Вас на винчестере мало места) диск. Здесь же можно обновить антивирус и проверить свой компьютер на вирусы.

2. Хакерские программы, их можно найти в "Работа с интернетом" - "Хакерство" - "Программы". Их описания в разделе справки Хакерство.

3. Пиратские программы: "Работа с интернетом" - "Пиратство" - "Программы". Собственно, там есть описание всех программ, но на всякий случай оно приведено здесь:
  • Копирование дисков — главные программы для пиратства, без них ничего не получится, они копируют диски.
  • Сжатие видео — если Вы будете выполнять задания, где у Вас попросят фильм, эти проги — то, что Вам нужно
  • Сжатие аудио — если клиент просит какой-либо музыкальный альбом, то без программ из этого раздела Вам не обойтись

4. Программы для разгона видеокарты. Находятся: "Тестирование железа" - "Разгон видеокарты" - "Программа для разгона". Пока что они все бесплатны. Ничем, в принципе (кроме различия в весе и операционки) друг от друга не отличаются.

Также некоторые виды софта Вы можете написать самостоятельно в разделе "Создание программ".


>> Начальное железо
> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Начальное железо

Внимание! Оригинальную статью можно найти на Сайте игры.

Автор оригинальной статьи: haM3r
Mailto: BVLAD36@BK.RU Автор обновленной статьи: FLYM
Написано на основе статьи haM3r'а "Как заработать много денег..." (ее вы можете скачать с Сайта игры), посвященный теме выбора начального железа.
К сожалению, данные статьи устарели, поэтому здесь приведена измененная версия.

В начале игры в зависимости от выбранного возраста вам могут либо сразу выдать компьютер и жилье, при этом вы получите порядка 3000 д. е. Тогда можете смело пропускать эту статью. При втором варианте вам выдадут в районе 19000 д. е., но у вас не будет компьютера и жилья, в третьем случае вы получите около 7000 д. е., при этому у вас не будет компьютера, но будет квартира.

В начале игры всегда возникает острая потребность в деньгах, поэтому ниже приведена рекомендуемая конфигурация, при которой у вас получится сэкономить больше денег. Обязательное оборудование выделено жирным шрифтом, остальное рекомендуется для комфортной игры. Цены приведены без скидок и действительны для CompEvo 4.0.2.

Таблица 2
Вид товара | Наименование | Магазин | Радиорынок
Материнская плата | Abit KT6 | 490 д. е. | 466 д. е.
Процессор | AMD Duron 700 MHz | 432 д. е. | 410 д. е.
Жёсткий диск | Seagate U4 6421 | 506 д. е. | 476 д. е.
Оперативная память | Corsair CAS | 379 д. е. | 356 д. е.
Видеокарта | ASUS V7100 | 516 д. е. | 495 д. е.
Оптический привод | Toshiba CD-M1402 | 428 д. е. | 411 д. е.
Монитор | Sony HMD-A400 | 801 д. е. | 761 д. е.
Клавиатура | Microsoft Natural | 89 д. е. | 85 д. е.
Мышь | Razer Boomslang | 139 д. е. | 135 д. е.
Блок питания | Sparkle 350W | 129 д. е. | 124 д. е.
Кулер | Alpha P125CM60 | 407 д. е. | 391 д. е.
Итого |  | 4316 д. е. | 4110 д. е.
Итого обязательные |  | 3393 д. е. | 3224 д. е.

Материнку, монитор и жёсткий диск лучше купить на радиорынке. Немного экономии не помешает. Правда, Вам могут подсунуть "битый" товар, поэтому, хотя, риск дело благородное, но сохраниться перед покупкой на радиорынке стоит. Кстати, неплохо покупать новые девайсы, когда в магазинах проходят скидки. Если денег на покупку компьютера не хватает, то можете взять кредит в банке. (IMHO очень полезная функция)


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
>> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Интернет

Интернет в игре, как и в реальности, предоставляет много возможностей.
Сайт и e-mail
От них растет ваш рейтинг, ну, еще приятно, когда у вас есть сайт с доменом второго уровня, на этом польза заканчивается. Минусы: на e-mail часто приходит спам, если какой-нибудь извращенец зашлет Вам большой файл, придется платить денежки за трафик.
Различные виды заработка
4 различных вида заработка принадлежат интернету. Это ответы на вопросы, хакерство, пиратство и сканирование/распечатка. Подробнее о них Вы можете прочитать в разделе Как добыть деньги?
Просмотр сайтов
В версии 4.0.2 число сайтов в World Wide Web Компьютерной эволюции ограничивается двумя:
  • http://www.shtirlitz.ru/ - развлекательный сайт с анекдотами, повышается настроение;
  • http://www.strashilki.ru/ - тоже развлекательный сайт, но со страшилками, повышается настроение.
Следующие сайты Вы можете скачать с Сайта игры:
  • http://www.happy.ru/ (by haM3r) — сайт будет радовать Вас=) Будьте осторожны! На некоторых систем игра может перестать отвечать на ваши клики после просмотра сайта!
  • http://www.ad.ru/ (by Ревенков Павел) — а этот сайт порадует Вас тремя баннерами и 25 д. е.
  • http://www.catalog.ru/ (by KRSK) — входит в состав мода krsk, на нем есть ссылки на все сайты CompEvo, при этом у Вас поднимается рейтинг!
  • http://www.html.uz/ (by pROCKrammer) — html-редактор. Ничего не добавляет, только жрет трафик;)
  • http://www.killbills.game.ru/ (by haM3r) — онлайн-игра, где требуется убивать монстров, прибавляет настроение.
  • http://www.ork.chat.ru/ (by haM3r) — довольно интересный чат, к характеристикам ничего не прибавляет.
  • http://www.search.uz/ (by pROCKrammer) — поисковая система с 3 сайтами, помимо поиска прибавляет рейтинг.
  • http://www.snake.game.ru/ (by haM3r) — онлайн-игра, старая добрая змейка, улучшается настроение.
  • http://www.xo.game.ru/ (by haM3r) — онлайн-игра, всем известные крестики-нолики, повышает настроение.
  • http://www.XProgrammers.com/ (by KRSK) — на сайте представлены несколько статей по программированию, растет рейтинг.


> Как добыть деньги?
>> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Характеристики игрока

В этом разделе будут рассмотрены основные характеристики: рейтинг и статус, настроение, а также отношение властей.
Рейтинг и статус
Статус напрямую зависит от рейтинга, он нужен только для подчеркивания определенных уровней, так что реальным параметров является рейтинг. Рейтинг можно заработать, покупая железо, лицензионный софт, от своего сайта в интернете вам идет постоянное повышение, то же самое и от e-mail, но помедленнее. Также рейтинг дается за посещение некоторых сайтов. За успешное написание программ вам также идет рейтинг. Рейтинг нужен для хака (когда рейтинг поднимет статус до "Продвинутый"), а также для устройства на работу.
Настроение
Не удалось скомпилировать программу и пришлось искать DLL? Пропалили при хаке? Испорченные болванки? Обманули при сканировании/печати? Плохо отдохнули? Пришли амбалы, когда вы пытались "настучать" при пиратстве? Или еще какие обстоятельства? Так ведь и умереть можно! Для повышения настроения идем в пункт "Отдых и развлечения" и выбираем отдых по душе, если повезет, настроение поднимется. Также в "Отдыхе и развлечениях" можно поставить игры на свой комп и играть в них, конечно же, если у Вас хорошая видеокарта. Настроение можно повышать также, удаляя папки на чужих компьютерах при хакерстве и посещая юмористические сайты ("Работа с интернетом" - "Выход в интернет"), наверняка вскоре появятся и плагины для улучшения настроения. Кроме того, если у вас комфортная квартира и престижное авто, ваше настроение становится лучше. Ну и, конечно, если в Вашей компьютерной жизни все хорошо и удается - настроение будет соответствующим.
Отношение властей
Если Вы часто попадаетесь на хаке и пиратстве, власти будут Вас, мягко говоря, недолюбливать. Исправить это можно, сдавая властям пиратский народ (см. подробнее в разделе Как добыть деньги?)


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
>> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Моды

Для начала определимся с тем, что же мы будем понимать под словом "мод". В CompEvo мод - это несколько игровых файлов с измененными/дополненными настройками, которые изменяют в основном какие-либо нюансы игрового процесса, например, добавление новых ОС, изменение ОС, под которыми идут программы, изменение железа и т. д.
Если честно, я побоялся ставить все это себе на CompEvo, но анализ файлов рассказывает все о каждом моде=)
Описание модов
К сожалению, для CompEvo 4 еще не вышло модов. Прочитать о модах для CompEvo 3 можно во второй версии справки, которую можно скачать с Сайта игры.

Изображения комплектующих

Начиная с CompEvo 4, в игру была введена возможность загрузки изображений комплектующих. Для того, чтобы вставить в игру свое изображение, сохраните его в папку Thumbnails игры в формате JPEG, назвав его Название_товара.jpg. Также можно скачать наборы изображений с Сайта игры.


>> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Как добыть деньги?

Вопрос добычи денег в игре CompEvo не стоит очень остро, так как способов множество, здесь будут рассмотрены все из них.

1. Работа
На работе Вам выплачивают ежемесячно зарплату. Посмотреть зарплату можно в списке работ. Здесь все должно быть просто: до 10 числа текущего месяца в главном окне кликаем по кнопке "Поиск работы", перед Вами список должностей, выбираем одну из доступных и жмем "Наняться". Вначале доступны не все работы, для открытия более хороших должностей нужно копить опыт (он же рейтинг), в разделе Характеристики игрока о рейтинге написано поподробнее. Кроме дохода работа не дает практически никаких преимуществ, только работа сис-админом и выше позволяет Вам писать программы.

2. Программирование
При максимальных знаниях, это, наверное, самый крупный источник дохода.

Этот вид заработка доступен только когда вы получите работу сисадмина. Для начала откройте "программное обеспечение" из главного окна, далее нажмите кнопку "Создание программ". Перед Вами окно программирования. Для начала зайдите по закладке "Повышение квалификации", если у Вас хватит денег, пройдите все курсы, это потом окупится. В последних версиях CompEvo на прохождение каждого раздела курса тратится месяц, так что выбор за вами: пройти больше курсов и получить квалификацию выше, либо выучить только нужный язык. Теперь переходите в "Написание программ", Вам предложат выбрать среду разработки, рекомендуется выбирать ту, которая у Вас установлена, т. к. при выборе иной Вы наверняка не сможете нормально написать программу. Теперь жмите кнопку "Поехали!". Вам предложат выбрать тип и написать название своей программы. После его ввода Вы можете написать исходный код и, если у Вас хватает знаний в программировании, еще DLL. DLL является хорошим способом расширить возможности вашей программы. После этого нажмите желательно отловить ошибки, что позволит сделать программу более стабильной. В процессе компиляции могут возникать ошибки, внизу в группе "Отладка" есть возможные варианты действия. Затем вы можете выпустить программу. После выпуска программы, если она окажется кому-нибудь нужной, ее можно выставить на аукционе, установив начальную цену. После продажи программы вы получите деньги, а также, если такой тип программ используется в игре, вам предложат установить ее себе на компьютер.

3. Пиратство
Здесь тоже все достаточно просто. Для начала вам нужен пишущий привод. После покупки открываете "Работа с интернетом" из главного окна, щелкаете по кнопке "Пиратство" и вот вы здесь. Для начала закупитесь программами для пиратства (раздел "Программы"), затем сходите на базар и прикупите болванок, теперь смело идите в пункт "Займись делом наконец!". Там Вы можете выбрать какую заявку будете выполнять, затем если вы катаете или фильм, или музыку, для начала нужно или сжать, или перегнать. (Кстати, чтобы закатать фильм Ваш оптический привод должен писать DVD, а также у Вас должно быть 5 Гб места на активном разделе жесткого диска, для музыки достаточно 1 Гб места) Затем жмите "Скопировать..." и процесс пошел. В первом столбике пишется скачка файл (или, если музыка или фильм перегоняются, то процесс кодировки), во втором использование процессора, в третьем запись на диск. Иногда случается, что болванки запорчены, ничего с этим не поделать... Также если вы будете очень много пиратить, власти обратят на Вас внимание, чтобы исправить положение Вам придется "постукачить", т. е. Вы можете нажать кнопку "Сообщить властям", они будут вам благодарны. Однако иногда случается так, что после сообщения властям к Вам в дверь стучатся два амбала и Вам придется дать им денежек.
4. Пиратство 2
При сообщение властям о пиратах (см. предыдущий пункт), Вы можете не только улучшить свое положение в глазах властей, но и получить деньги, если вы помогли поймать человека, которого давно ищут. Правда, если к Вам придут амбалы, платить деньги будете Вы, но как говорится, риск дело благородное, так что можете испытать свою удачу в этом виде заработка.
5. Сканирование и распечатка
Для выполнения этих заданий нужно запастись принтером и сканером. После произведения покупок направляемся "Работа с Интернетом" - "Сканирование и распечатка". Далее выбираем работу по вкусу и жмем соответственно "Сканирование" либо "Распечатка". Ждем и, если клиент оказался добропорядочным (что случается далеко не всегда), получаем денежки.
6. Хакерство
Хак подробно рассмотрен в разделе "Хакерство". Если повезет, это вполне неплохой источник дохода и улучшения настроения.
7. Ответы на вопросы
Идем в "Работа с интернетом", затем в "Ответы на вопросы", там есть две секции: "Перевод" - там вам нужно перевести слово, предложение или расшифровать аббревиатуру; "Вопросы для профи" - вопросы, связанные с компьютерами. Обе секции вопросов достаточно легкие, так что зарабатывать деньги вполне реально.
8. Плагины
К сожалению, для CompEvo 4 еще нет плагинов, при помощи которых можно зарабатывать, но скорее всего они появятся, так что держите на заметке.
9. Банк
Из главного окна игры вызовите окно "Банк", выберите количество денег, которые Вы хотите вложить и нажмите кнопку "Вклад", теперь Вы будете получать от банка ежегодно проценты (они написаны в том же окне).
10. Банк 2
Деньги в банк можно не только вкладывать, но и занимать у него. Для этого направляйтесь в окно "Банк", выбирайте сумму, время, на которое хотите занять деньги, затем жмите кнопку "Занять". Желательно деньги к тому сроку отдать, иначе вам будет натекать Пеня, которую тоже придется оплатить. Узнать сколько осталось времени до выплаты можно, наведя мышь на размер кредита в группе "Банк" в главном окне.
11. Случайный заработок
Время от времени Вам будут выдаваться сообщения о том, что Вы нашли кошелек, выиграли в лотерее деньги, получили посылку или сделали какую-то работенку. Несерьезный способ заработка.
12. Читы
К игре есть приличное число читов, в том числе и на деньги, однако Вы их узнаете только после прохождения игры.


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
>> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Установка музыки в любом формате

Внимание! Версия статьи в справке весьма изменена. Вы можете скачать оригинальную статью с Сайта игры.

Автор статьи: Пулатов Сардор
Mailto: SARDOR90@GMAIL.COM
URL: CELOVERS.NAROD.RU

Для начала у Вас, конечно же, должна быть музыка в каком-либо формате. В нашем примере это будет mp3.
Зайдите в директорию с игрой. В ней есть файл Config.ini, откройте его любым текстовым редактором. В этом файле есть строчка, начинающаяся с "MusicFormats=", у меня она 7-я. После знака "=" (или можно в конце строки, но тогда знак ";" должен быть перед расширением музыки) пропишите "*.формат_Вашей_музыки;", например, "*.mp3;". Сохраните и закройте этот файл.

Теперь скопируйте музыку в формате, который Вы указали в файле Config.ini, в папку Music, находящуюся в директории с игрой, при этом переименуйте свой музыкальный файл в "Music N", где N - число от 1 до бесконечности, обозначающее номер вашей композиции.

Вот и все, теперь в игре есть Ваша музыка.


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
>> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Плагины: что? зачем? как?

Плагины были введены в игру в версии 3.3 Beta 1. Для CompEvo 3 было достаточно много плагинов, однако, в CompEvo 4 были внесены некоторые изменения, и плагины от 3-й версии не работают, но если Вы умеете программировать, то на Сайте игры выложено руководство по созданию плагинов. Вообще плагины добавляют в игру некоторые новые функции и расширяют ее. Ниже в этом разделе описан пока что единственный плагин для CompEvo 4, доступный на момент написания на Сайте игры. После скачивания распакуйте плагин (если он заархивирован) в папку Plugins в директории с игрой. После этого запустите Компьютерную эволюцию и загрузите/начните новую игру. Зайдите в меню с буквой "K", выберите пункт "Настройки", затем "Плагины", выберите желаемый плагин и запустите его (щелчок по кнопке "Запуск", либо нажатие Enter, либо двойной щелчок по названию плагина).
Описание плагинов
Название TimeMachine
Описание автора Плагин, позволяющий изменять скорость игры в часах без перезапуска.
Автор haM3r
Награда Первый плагин для CompEvo 4 | Временно не работает=(
Альтернативное описание Первый плагин, перекочевавший в CompEvo 4. Ни добавить, ни убавить, все точно и правильно: при помощи этого плагина можно изменять скорость игры без перезапуска. В версии 4.0.3 перестал работать (надеюсь, скоро эта ситуация будет исправлена).
Название 24 Hours
Описание автора Плагин для установки скорости течения времени 1 сут/сек..
Автор Rix
Альтернативное описание Совершенно правильное описание, при запуске плагина вам выдается сообщение, о том, что скорость установлена на 24 ч/сек, это действительно так;).

Руководство по созданию плагинов для игры Компьютерная эволюция 4

  1. Введение
  2. Формат плагинов
  3. Настройка Delphi
  4. Настройка Visual C++ .NET
  5. Описание функций
  6. Принципы работы со значениями в главной программе
  7. Значения элементов массивов
  8. Пример плагина на Delphi
  9. Пример плагина на Visual C++i
  10. Установка плагина
  11. Обратная связь
Введение

Начиная с версии 3.3 Beta 1 в игре появилась использовать плагины. Плагины - набор расширений к игре. Они добавляют новые возможности в игру, могут изменять ее ход и т.д.

Примечание 1: здесь и далее будут рассматриваться примеры плагинов для текущей версии (на данный момент текущей версией является 4.0.3). Это связано с тем, что в более ранних версиях могли быть найдены ошибки или недоступны некоторые параметры.
Примечание 2: Рассматриваемый здесь материал рассчитан на человека знакомого с языком программирования Object Pascal или С++, в частности с системой проектирования прикладных программ Delphi или Visual Studio. Также очень желательны навыки работы с указателями и функциями.
Примечание 3: Написанные плагины несовместимы с версиями игры ниже 4.0.3.
Примечание 4: Поскольку в программе для строк используется тип данных shortstring - запись в строковые параметры для Visual C++ невозможна. А чтение строк должно начинаться не с нулевого символа, а с первого. Однако если вы используете Borland C++ Builder, то вместо создания типа char*, можно создать тип shortstring*, тогда запись в строковые параметры будет возможна..

Формат плагинов

Все плагины должны быть сделаны в виде динамических библиотек. То есть иметь расширение dll. Другие форматы плагинов будут проигнорированы.

Настройка Delphi

Создание плагина в Delphi начинается с создания DLL. Создайте DLL и сохраните проект в папку Plugins, которая находится там, где вы установили игру. Можете нажать Ctrl+F9, чтобы убедиться, что был создан файл имя_вашего_проекта.dll. Поскольку в момент загрузки плагина ему передается управление, то неплохо было бы автоматически запускать игру и во время передачи управления плагину отслеживать возникающие события. Это даст возможность ставить точки прерывания и выполнять плагин по шагам. Активизируем данную возможность. Для этого в Delphi выбираем пункт Run -> Parameters.... В появившемся окне устанавливаем следующие параметры: Host Application - путь_к_исполняемому_файлу_игры; Working Directory - папка_где_у_вас_установлена_игра. На рисунке справа показано данное окно.

Настройка Visual C++ .NET

Создайте DLL с использованием библиотек MFC и сохраните проект в папку Plugins. Теперь откройте окно свойств проекта (Project -> Имя_проекта_Properties). На рисунке слева показано окно настройки проекта. В разделе Debugging, параметр Command, укажите путь к exe файлу игры. А параметру Working Directory присвойте путь к каталогу игры. В разделе Linker -> General установить параметр Output File равным имя_проекта.dll.

Описание функций

В плагине обязательно должны присутствовать две функции. Одна из функций - данные об авторе. Другая - управляющая функция. Описание первой функции выглядит следующим образом:

function PluginAuthor:Pchar;
begin
PluginAuthor:='||';
end;

Для Visual C++ это будет выглядеть так:

extern "C" __declspec(dllexport) char* PluginAuthor(void)
{ return "||"; }
Здесь функция имеет пустой список формальных параметров и возвращает только один единственный параметр - данные об авторе. Этот параметр состоит из 3-х секций, каждая из которых разделяется знаком '|'. Первая секция - Имя автора плагина. Вторая секция - E-mail автора плагина. Третья секция - краткое описание плагина.
Вторая функция выглядит так:
function PluginExec(I,R,S,B:pointer;ISize,RSize,SSize,BSize:integer):boolean; stdcall;
begin
PluginExec:=true;
end;
И соответственно функция на Visual C++:
extern "C" __declspec(dllexport) __stdcall PluginExec(void *I, void *R, void *S, void *B)
{ return true; }
В отличие от предыдущей функции данная функция имеет несколько формальных параметров и возвращаемый параметр типа boolean (bool для Visual C++). Первые четыре формальных параметра в функции имеют тип Pointer (указатель без типа - void *). Это указатели на массив указателей: I - указатель на массив указателей на тип integer (int); R - тип real (double); S - тип shortstring (char*); B - тип boolean (bool). Параметры типа integer это длины соответствующих им массивов: ISize - длина массива указателей на тип integer; RSize - тип real; SSize - тип shortstring; BSize - тип boolean (для Visual C++ данные параметры необязательны). Данная функция возвращает в главную функцию значение true или false. True свидетельствует о том, что плагин выполнился нормально. Если вы используете в исходном коде блоки try и except, то в зависимости от ситуации передавайте значение true или false.

Принципы работы со значениями в главной программе

Понятно, что создание плагинов было бы бессмысленным, если бы они не меняли какие-то значения в главной программе. Для доступа к значениям хранящимся в главной программе необходимо объявить имена типов указателей на массивы и произвести операцию разыменования. Рассмотрим, как это делается:

type
IntMas=array of ^integer;
Данная запись создает тип IntMas, который является массивом указателей на тип integer. Аналогичные записи можно сделать и для других типов массивов:
RealMas=array of ^real;
StrMas=array of ^shortstring;
BoolMas=array of ^boolean;
Далее в теле функции PluginExec осуществляем следующие операции:
var
Integers:IntMas;
begin
setlength(Integers,ISize);
Integers:=I;
Здесь мы объявляем переменную Integers типа IntMas. Задаем длину массива Integers(поскольку тип IntMas как раз и является массивом указателей), используя формальный параметр ISize. Аналогичную операцию проводим для остальных массивов:
var
Reals:RealMas;
Strings:StrMas;
Booleans:BoolMas;
begin
setlength(Reals,RSize);
setlength(Strings,SSize);
setlength(Bolleans,BSize);
Reals:=R;
Strings:=S;
Booleans:=B;
Теперь можно работать со значениями, хранящимися в главной программе, используя операцию разыменования:
Reals[0]^
Используя данную запись мы получаем значение (операция разыменование), которое хранится в массиве указателей на вещественные числа под номером 0 (нумерация всех массивов в плагинах должна начинаться с 0). Под номером 0 хранится рейтинг игрока. Таким образом, если мы к примеру напишем такую запись:
ShowMessage(IntToStr(Reals[0]^));
...на экран выведется сообщение с текущим рейтингом игрока. Если же мы хотим изменить рейтинг игрока к примеру на 10 очков, то запись должна быть такой:
Reals[0]^:=Reals[0]^+10;
В конце плагина, в разделе exports необходимо обязательно указывать имена функций PluginExec и PluginAuthor.
exports PluginExec, PluginAuthor;
Теперь вкратце рассмотрим реализацию на Visual C++:
typedef int* intp;
typedef double* realp;
typedef char* charp;
typedef bool* boolp;

IntMas=static_cast(I);
CharMas=static_cast(S);
RealMas=static_cast(R);
BoolMas=static_cast(R);

if (*IntMas[13]>90)
MessageBox(NULL,"Отношение властей нормальное.","Сообщение из плагина",MB_OK|MB_ICONINFORMATION);
Кроме этого следует в .def файле проекта, в разделе EXPORTS прописать следующие строки:
PluginAuthor @1
PluginExec @2

Значения элементов массивов

Далее приводится таблица значений элементов массивов, которые можно использовать в плагинах.

Целые числа
Номер элемента | Значение
0 | Текущий месяц
1 | Текущий год
2 | Текущий день
3 | Возраст игрока
4 | Сумма вклада в банке
5 | Процент вклада в банке
6 Нумерация текущего статуса игрока:
0 - человек
1 - чайник
2 - юзер
3 - продвинутый
4 - хакерок
7 | Количество записанных дисков CD-ROM
8 Количество знаний по Assembler (аналогично C , Pascal и Basic):
0 - ничего не знаете
1 - вступили на курсы
2 - прошли 1-й этап обучения
3 - прошли 2-й этап обучения
4 - Закончили обучение
9 | Количество знаний по Pascal
10 | Количество знаний по C
11 | Количество чистых дисков CD-ROM
12 | Количество написанных программ
13 | Отношение властей
14 | Скорость работы сканера
15 | Скорость печати принтера
16 | Безопасность монитора
17 | Скорость работы с интернетом
18 | Надежность ИБП
19 | Производительность процессора
20 | Производительность добавляемая при разгоне процессора
21 | Тактовая частота шины FSB
22 | Процент разгоняемости процессора
23 | Множитель на процессоре
24 | Температура процессора
25 | Частота вращения кулера
26 | Частота вращения шпинделя жесткого диска
27 | Объем жесткого диска
28 | Ежемесячная зарплата игрока
29 | Тактовая частота ядра на видеокарте
30 | Тактовая частота памяти на видеокарте
31 | Процент разгоняемости видеокарты
32 | Объем установленной на видеокарте памяти
33 | Производительность добавляемая при разгоне видеокарты
34 | Производительность видеокарты
35 | Производительность добавляемая при включении технологии Hyper Threading
36 | Скидка на винчестеры (если в магазине проходит акция)
37 | Скидка на видеокарты (если в магазине проходит акция)
38 | Скидка на процессоры (если в магазине проходит акция)
39 | Объем установленной оперативной памяти
40 | Тип установленной оперативной памяти (PC 2100, 2700, и т.д.)
41 | Скорость чтения дисков CD-ROM
42 | Скорость записи дисков CD-R
43 | Скорость записи дисков CD-RW
44 | Скорость записи дисков DVD-R
45 | Скорость записи дисков DVD-RW
46 | Скорость течения времени (часов в секунду)
47 | Количество взломанных Unix-машин
48 | Количество взломанных Windows-машин
49 | Количество арестов
50 | Степень неприятия к последней запущенной игре
51 | Количество испорченных при записи болванок
52 | Текущий час
53 | Время с момента последнего обновления антивирусных баз
54 | Производительность добавляемая после дефрагментации диска
55 | Сумма кредита игрока
56 | Процент кредита
57 | Количество дней до конца срока кредита
58 | Время в днях со времени последней дефрагментации
59 | Количество знаний по Basic
60 | Степень прозрачности главного окна
61 | Количество значий по программированию (общий рейтинг)
62 | Диагональ используемого монитора
63 | Количество предоплаченного трафика за интернет
64 | Температура видеокарты
65 | Ежемесячная стоимость размещения сайта на платном хостинге (0 - бесплатный хостинг)
66 | Ежемесячная квартплата
67 | Престиж купленного автомобиля
68 | Комфорт купленного жилья
69 | Размер активного раздела
70 | Свободное место на активном разделе
71 | Количество дней оставшихся до завершения обучения игрока программированию
72 | Язык изучаемый игроком на курсах программирования (56 - Basic; 57 - Pascal; 58 - Assembler; 59 - C++)

Вещественные числа
Номер элемента | Значение
0 | Рейтинг игрока
1 | Деньги игрока
2 | Настроение игрока
3 | Напряжение на процессоре
4 | Сумма пени снимаемого с игрока при просрочке кредита

Строковые параметры
Номер элемента | Значение
0 | Рабочая папка программы
1 | Имя игрока
2 | Чипсет материнской платы
3 | Чип видеокарты
4 | Тип разъема на материнской плате куда может быть установлена видеокарта
5 | Тип операционной системы(установленной на активном разделе)
6 | Тип разъема видеокарты для подключения к материнской плате
7 | Тип среды разработки(установленной на активном разделе)
8 | Дата последнего обновления антивирусных баз
9 | Имя последней запущенной пользователем игры
10 | Тип установленной оперативной памяти (DDR, DDR2 и т.д.)
11 | Адрес сервера обновления антивирусных баз
12 | Комментарий к сохраненной игре
13 | Метка активного раздела
14 | Файловая система активного раздела
15 | Операционная система установленная на активном разделе
16 | Установленная среда разработки(здесь и далее идут программы установленные в систему находящуюся на активном разделе, при том что сами программы могут быть расположены как на логических разделах, так и на активном основном)
17 | Установленный антивирус
18 | Установленный противоспамный фильтр
19 | Установленный брандмауер
20 | Установленная программа дефрагментации
21 | Установленная программа для работы с разделами жесткого диска
22 | Установленный браузер
23 | Установленный файловый менеджер
24 | Установленная программа для тестирования компьютера
25 | Установленная программа для копирования дисков
26 | Установленный аудио конвертер
27 | Установленный видео конвертор
28 | Установленная программа для разгона видеокарты

Флаговые параметры
Номер элемента | Значение
0 | Имеет ли игрок самую престижную работу (начальник)
1 | Возможность записи DVD дисков
2 | Будет ли игроку предоставлено 100 Мб преоплаченного трафика за интернет при покупке модема (если в магазине проходит соответствующая акция)
3 | Делал ли игрок экстримальный разгон видеокарты
4 | Проходит ли игрок обучение на курсах программирования

Пример плагина на Delphi

library Test;

uses
Dialogs, SysUtils;

{$R *.res}

type IntMas=array of ^integer;

function PluginAuthor:Pchar;
begin
PluginAuthor:='Ревенков Павел|RPsoft@mail.ru|Тестовый плагин';
end;

function PluginExec(I,R,S,B:pointer;ISize,RSize,SSize,BSize:integer):boolean;
var
MyMas:IntMas;
begin
setlength(MyMas,ISize); MyMas:=I;
ShowMessage('Тестовый пример плагина. Текущий месяц - '+IntToStr(MyMas[0]^));
PluginExec:=true;
end;

exports PluginExec, PluginAuthor;

end.

Пример плагина на Visual C++

typedef int* intp;
typedef double* realp;
typedef char* charp;
typedef bool* boolp;

extern "C" __declspec(dllexport) char* PluginAuthor(void)
{ return "Ревенков Павел|RPsoft@mail.ru|Тестовый плагин"; }

extern "C" __declspec(dllexport) __stdcall PluginExec(void *I, void *R, void *S, void *B)
{
intp *IntMas;
charp *CharMas;
realp *RealMas;
boolp *BoolMas;

IntMas=static_cast(I);
CharMas=static_cast(S);
RealMas=static_cast(R);
BoolMas=static_cast(R);

if (*IntMas[13]>90)
MessageBox(NULL,"Отношение властей нормальное.","Сообщение из плагина",MB_OK|MB_ICONINFORMATION);

return true;
}
Установка плагина

После того, как вы создали окончательный dll файл, сохраните его вместе с файлами необходимыми для работы плагина (картинки, музыка и т.д.) в папку Plugins, которая находится там, где у вас установлена игра.

Обратная связь

Если вам что-то непонятно в этом руководстве или вы хотите задать мне какие-то вопросы, пишите мне на e-mail: RPsoft@mail.ru


> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
>> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Создание сайта

Автор статьи: Пулатов Сардор
Mailto: SARDOR90@GMAIL.COM
URL: CELOVERS.NAROD.RU

Внимание! Версия статьи в справке весьма изменена. Вы можете скачать оригинальную статью с Сайта игры.

Сайты в игре Компьютерная Эволюция появились недавно (с версии 3.5.0). В ней есть только 2 сайта "shtirlitz.ru" и "strashilki.ru" (на сайте есть еще 10 — прим. ред.), но вы можете поставить туда и свой сайт, это не трудно.

Вам понадобится:
  • Любой текстовый редактор (например, Блокнот)
  • Знание html (или Вы можете воспользоваться визуальным редактором html)

Итак, поехали. Для начала создадим папку, например rpprogs.narod.ru в директории Sites, которая находится в папке игры, название этой создаваемой директории будет адресом нашего сайта. Далее давайте создадим страницу, которая будет называться, page.htm (название должно быть именно таким! - прим. ред.) Наберите в текстовом редакторе код страницы и сохраните в файл page.htm. Простейший пример кода страницы:

<html>
<body>
<h1>Это пример</h1>
</body>
</html>

После создания страницы в одной папке с ней создайте файл page.ini:

[Options]
Caption=Заголовок
AddPoints=Money
Count=25

[About]
Comment=Комментарий
Author=Автор
Mail=E-mail автора

Замените все параметры на свои.
Описание параметров:

  • Caption - заголовок сайта
  • AddPoints - что добавляется при посещении сайта:
    1. Mood - Настроение
    2. Money - Деньги
    3. Programming - Рейтинг
  • Count - как изменяется предыдущий параметр (число)
  • Comment - комментарий к сайту
  • Author - автор сайта
  • Mail - e-mail автора

Теперь вы знаете как делать сайты в CompEvo;)


>> Начинаем игру
> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Начинаем игру

Итак, Вы запустили Компьютерную эволюцию, перед вами окно, которое вы можете увидеть на рисунке справа. В нем Вы должны будете ввести свое имя (если оно не будет введено, Вас нарекут Мистером Х), по желанию вы можете указать путь к файлу-изображению, который будет использован как Ваше фото, укажите свой игровой возраст, а также Вас попросят выбрать скорость течения игры. После выполнения этих действий нажмите кнопку "Поехали!" для начала игры.
После нажатия кнопки "Поехали!" Вы попадете в главное окно программы. В нем вы можете видеть множество групп с характеристиками Вас и Вашего мнимого компьютера. Они собраны в группы (табл. 1). Каждую группу можно свернуть, щелкнув по заголовку, чтобы распахнуть группу обратно, снова щелкните по заголовку. Если распахнутая группа войдет в окно программы, она будет распахнута, иначе вы увидите сообщение об ошибке.

Чтобы открыть меню игры нажмите на кнопку с буквой "K" (На стандартном скине "Keramik", на других может быть иное обозначение меню), здесь Вы можете начать новую игру, включить паузу (она будет включена, пока Вы не нажмете кнопку "OK"), загрузить сохраненную игру, сохранить игру (рекомендуется сохранять игру под тем же именем, что и игрок, тогда при выборе этого игрока автоматически будет грузиться игра), посмотреть рекорды (т. е. игрока, дожившего до 2007 года и его характеристики), изменить настройки (включение/выключение: автоматического сохранения, музыки, новостей, прозрачности; также Вы можете переключаться между оконным и полноэкранным режимами, проверить обновления или включить автообновление, изменить скин или включить плагин (скины и плагины можно скачать с сайта RPPROGS.NAROD.RU), посмотреть историю игры, посмотреть информацию об игре и выйти из нее.

Таблица 1
Ваш компьютер | Здесь Вы можете увидеть какое оборудование установлено на Вашем компьютере. Поднеся мышь к названию какого-либо устройства, вы можете узнать его характеристики: напр., объем ОЗУ, тип ОЗУ, объем винчестера и т. д.
Установленные программы | Названия установленных у Вас ОС, Среды разработки (для написания программ), Антивируса (поднеся мышь к его названию можно узнать дату последнего обновления), Противоспамного фильтра, Брандмауера (для защиты компьютера), Дефрагментатора диска, Оператора диска (для управления разделами), Браузера (для просмотра сайтов), Файлового менеджера (для просмотра папок чужого компьютера при взломе), Программы-тестера (для тестирования характеристик вашего компьютера), программ для Копирования дисков, Сжатия аудио и Сжатия видео (для пиратства).
Интернет | Вы можете увидеть свой сайт в интернете и e-mail, если они у Вас, конечно есть. Также здесь написано количество полученного Вами спама и предоплаченный трафик.
Ваш статус | Здесь показываются Ваш возраст, настроение, жилье, машина, работа, денежные средства, рейтинг, статус и отношение к Вам властей. При поднесении мыши к полосам состояния настроения, рейтинга и отношения властей. Если поле представлено полоской состояния, то вы можете поднести к нему мышь, чтобы узнать более точную информацию.
Хакерство | В этой группе можно посмотреть, сколько хакерских программ приобретено, сколько раз Вас арестовывали, а также количество удачно взломанных компьютеров. При наведении мыши на число взломанных компьютеров Вам покажут, сколько из них были на Windows, а сколько на Unix; наведя мышь на число программ, Вам покажут какие это программы.
Пиратство | Здесь показаны количество пустых болванок и количество записанных Вами дисков (наведя мышь на это число, Вы узнаете число запорченных болванок)
Программирование | Здесь Вы можете узнать какие языки программирования Вы знаете, а также, сколько вы программ написали.
Банк | Здесь написаны Ваши вклад, кредит и проценты банка.
Данные по материнской плате, процессору и видеокарте | В этих трех группах вы можете узнать дополнительные данные о вашей материнской плате, процессоре и видеокарте.

В предыдущих версиях CompEvo существовала группа "Управление игрой", в которой находились кнопки для открытия окон поиска работы, отдыха и т. д. Теперь кнопки управления игрой находятся в главном меню внизу окна.
Скины
Информация про скины помещена в этом разделе, т. к. устроить рабочее место по своему вкусу - это первое, что должен сделать каждый. На Сайте игры Вы можете скачать скины по своему вкусу. Если же Вы и сами имеете в себе талант дизайнера, качайте с того же сайта и Изготовитель скинов. Делайте свои скины! Если скин будет хорошим, место на сайте ему обеспечено! :-)
Плагины
Плагины расширяют возможности игры, что представляет практически неограниченные возможности по улучшению игры, скачать плагины можно с Сайта игры, там же можно найти руководство по самостоятельному созданию плагинов.
Обновление
Не забывайте время от времени обновлять программу, это можно сделать на Сайте игры, однако, если Вам лень постоянно заходить на сайт, в меню настройки Вы можете проверить игру на обновления, а также включить режим автообновления, который будет время от времени проверять, есть ли в интернете новые версии игры. И помните! Вместе с каждой версией в игре становится меньше багов и больше возможностей!
Игровая жизнь
Теперь после рассмотрения игрового интерфейса пару слов об игре. Для начала вам понадобится жилье, которое можно купить, нажав в главном меню на кнопку "Домохозяйство", а затем пройти в раздел "Жилье". Жилье различается по комфорту, цене и квартплате, выбирайте то, что больше вам по душе и по карману. После покупки жилья для успешной игры вам потребуется компьютер, о выборе начального железа по низким ценам читайте в соответствующем разделе. Также вы можете купить автомобиль, они различаются по престижу и цене. Если у вас нет автомобиля, то вы будете тратить деньги для поезда на работу, собственная машина решит эту проблему. Не забывайте, что престижное авто и комфортное жилье будут влиять на ваше настроение, а хорошая машина может поднять ваше положение в глазах начальства.

Итак, в этом разделе справки Вы кратко ознакомились с главным окном игры и теперь можно смело начинать играть, более подробную информацию можно найти в других разделах.


>> Содержание справки
> Как добыть деньги?
> Характеристики игрока
> Железо, софт: краткое описание
> Интернет
> Создание сайта
> Хакерство
> Плагины: что? зачем? как?
> Музыка в любом формате
> Моды и изображения комплектующих
> Содержание файлов

> Сайт игры

Содержание справки

Если Вы не можете найти интересующую Вас тему в справке, в этом разделе обозначены большинство из них (в алфавитном порядке) с указанием разделов. Если вы хотите найти что-либо на этой странице, нажмите Ctrl+F и введите часть слово, например, чтобы найти пункт "Создание программ", наберите "прог" или "созд" и т. п.

E-mail — Интернет
MP3 — Музыка в любом формате
Автомобиль — Начинаем игру
Взлом ICQ — Хакерство
Вклад денег в банк — Как добыть деньги?
Выбор возраста — Начинаем игру
Выключение музыки — Начинаем игру
Главное меню — Начинаем игру
Главное окно — Начинаем игру
Деньги — Как добыть деньги?
Игры — Характеристики игрока, Интернет
Изменение главного окна — Начинаем игру
Изменение скорости игры — Плагины: что? зачем? как?
Изображения комплектующих — Моды и изображения комплектующих
Железо — Железо, софт: краткое описание, Начальное железо
Жилье — Начинаем игру
Загрузка игры — Начинаем игру
Кредит в банке — Как добыть деньги?
Моды — Моды и изображения комплектующих
Своя музыка — Музыка в любом формате
Начало игры — Начинаем игру, Начальное железо
Необходимое железо — Железо, софт: краткое описание
Обновление — Начинаем игру
Описание софта — Железо, софт: краткое описание
Ответы на вопросы — Как добыть деньги?
Отношение властей — Характеристики игрока
Пауза — Начинаем игру
Пиратство — Как добыть деньги?
Плагины — Плагины: что? зачем? как?
Программирование — Как добыть деньги?
Проверка на вирусы — Железо, софт: краткое описание
Работа в интернете — Как добыть деньги?
Работа в реале — Как добыть деньги?
Разгон видеокарты/процессора — Железо, софт: краткое описание
Разделы жесткого диска — Железо, софт: краткое описание
Редактирование игровых файлов — Содержание файлов, Создание сайта, Моды и изображения комплектующих
Рейтинг — Характеристики игрока
Рекорды — Начинаем игру
Сайты — Интернет
Свой сайт — Интернет
Сканирование и распечатка — Как добыть деньги?
Скины — Начинаем игру
Случайный доход — Как добыть деньги?
Создание программ — Как добыть деньги?
Создание сайта — Создание сайта
Софт — Железо, софт: краткое описание
Софт для пирата — Железо, софт: краткое описание
Софт для хакера — Хакерство
Сохранение игры — Начинаем игру
Статус — Характеристики игрока
Тест железа — Железо, софт: краткое описание
Улучшение отношения властей — Как добыть деньги?
Хакерство — Хакерство
Читы — Как добыть деньги?